Those working on this mod do so in their own free time and for no pay.
Show your support for them by enabling ads on this site!

- Chatbox: For random chatting, mod questions/suggestions go in the actual forums.

Author Topic: Imperial Civil War 2.3 Bug Report Thread  (Read 378 times)

0 Members and 1 Guest are viewing this topic.

July 15, 2019, 03:33:31 AM

Offline Corey

  • Mod Leader
  • Administrator
  • Emperor
  • *****
  • Posts: 7,503
  • Approval: +410/-80
  • Dream Crusher
    • View Profile
Imperial Civil War 2.3 Bug Report Thread
« on: July 15, 2019, 03:33:31 AM »
Please report any bugs that you find in 2.3 here. Please also refrain from double-reporting issues that have already been posted except to add more information.
I also have a YouTube channel where I talk about mod development and gaming, do tutorials, and Let's Plays. If you like the content, consider supporting it on Patreon


July 15, 2019, 03:50:22 AMReply #1

Offline fubbles

  • Stormtrooper
  • **
  • Posts: 8
  • Approval: +0/-0
    • View Profile
Re: Imperial Civil War 2.3 Bug Report Thread
« Reply #1 on: July 15, 2019, 03:50:22 AM »
I was playing Art Of War default era on Admiral as Eriadu Authority. I invaded Bespin and landed 2-M tanks, Maximilian Veers in his AT-AT and another AT-AT and deployed both storm troopers. As my forces were moving out and engaging, the 2-M tanks targeted and killed my own infantry deployed by the AT-AT but I don't know if it was from Veers or the other one (or both). I had already taken multiple other planets at this point and had deployed Veers along with AT-AT and 2-M before and this is the first time I noticed the tanks targeting my infantry.

August 09, 2019, 08:00:29 AMReply #2

Offline Xardovany

  • Recruit
  • *
  • Posts: 3
  • Approval: +0/-0
    • View Profile
Re: Imperial Civil War 2.3 Bug Report Thread
« Reply #2 on: August 09, 2019, 08:00:29 AM »
I was playing with the Hand, and the medium tank wasn't getting repaired by the repair station.

August 12, 2019, 02:12:30 PMReply #3

Offline AdmiralCypher

  • Stormtrooper
  • **
  • Posts: 8
  • Approval: +0/-0
    • View Profile
Re: Imperial Civil War 2.3 Bug Report Thread
« Reply #3 on: August 12, 2019, 02:12:30 PM »
Hi, I recently made the switch to Era 2 by building Thrawn, and after a little while the game appears to be locked on pause. Pressing the pause button or the fast forward button achieves nothing, and closing the game and reloading the save hasn't helped. I can't move any fleets ,the little graphics on the trade routes between my planets aren't moving (as they do on pause) but there's no red "resume" button on the top. I can queue building and rearrange fleets on planets just like on pause, but I can't actually invade anyone.

I'm bummed because I've just about got Thrawn ready to go, but I can't actually do anything in game. Has anyone else hit an issue like this? Is it a problem with the base game maybe? Is there any hope to rescue my save?

Thanks in advance!
"Engage the enemy more closely"


September 02, 2019, 12:10:19 AMReply #4

Offline the_trots

  • Brevet Admiral
  • ****
  • Posts: 79
  • Approval: +4/-3
    • View Profile
Re: Imperial Civil War 2.3 Bug Report Thread
« Reply #4 on: September 02, 2019, 12:10:19 AM »
Art of War as the NR, starting in era 1.

Somebody killed Thrawn or we hit the week limit and the game jumped to era 4 l, skipping era 3.  Lost Mon Motha and never gained Leia as well.  The only hero I gained was Ackbar's Galactic Voyager. I feel I should have gained some more heros with this jump.

I'll also add the last era progression update was about killing Isard.

September 07, 2019, 03:20:05 PMReply #5

Stephen Coman

  • Guest
Re: Imperial Civil War 2.3 Bug Report Thread
« Reply #5 on: September 07, 2019, 03:20:05 PM »
I've been having an odd issue crop up and haven't seen anything on how to fix it.  Basically, I can't save.  When running a galactic campaign I can occasionally save one time on a file but any subsequent saves will not work.  The game freezes and becomes completely unresponsive and has to be manually shut down.  The attempted save then becomes corrupted and crashes the game when loaded.  My brother runs the same mod and hasn't had this problem and I have attempted reinstalling the game to fix it.  Both my brother and I use the Steam version so I don't know if this is having an effect.  My first instinct might be my OS but I don't know if that has any true bearing (I use win7 and my bro uses win10).  I don't believe this to be a hardware or software issue on my end but I can't see any other overt reason that is causing this problem for me and not my brother.  If anyone else has had this problem I would really appreciate some advice.  Just to clarify, this issue only started after the 2.3 update, I did not have any saving issues before this.

September 07, 2019, 05:27:10 PMReply #6

Offline derp

  • Rear Admiral
  • *****
  • Posts: 152
  • Approval: +4/-2
    • View Profile
Re: Imperial Civil War 2.3 Bug Report Thread
« Reply #6 on: September 07, 2019, 05:27:10 PM »
Bandomeer in the Dark Empire GC, I invade with my evil Luke Skywalker (Empire) and after some ground combat the game crashes.
"I am not the Lord Darth Vader--I do not spend my men recklessly. Nor do I take their deaths lightly."
Grand Admiral Thrawn

 

Those working on this mod do so in their own free time and for no pay.
Show your support for them by enabling ads on this site!