Those working on this mod do so in their own free time and for no pay.
Show your support for them by enabling ads on this site!

- Chatbox: For random chatting, mod questions/suggestions go in the actual forums.

Author Topic: Bug with heroes and autocast (Huge credits lost)  (Read 100 times)

0 Members and 1 Guest are viewing this topic.

June 04, 2018, 03:30:20 AM

JuanK

  • Guest
Bug with heroes and autocast (Huge credits lost)
« on: June 04, 2018, 03:30:20 AM »
Hi! First of all, the mod is great and really enhances Sins after you get boring with vanilla factions.

Now the problem:

When you start a battle the autocast for heroes is enabled by default, so the first time you research them will autospam at your capital.
Until there this makes sense, but after you have the hero (in my case the Executor with the Pentastar Alignment) you will be charged with the same amount of credits again and again after the cooldown expires and autocast gets triggered again (seems not to affect the other resources), but obviously you won't get another hero because it is already on the field.

I was like 40 minutes looking for a drain in my eco, thinking that was maybe my huge fleet upkeep, but no, 10000 credits where dissapearing even if I wasn't fighting something. Even worst is the fact that it wont charge you if you have not enought money (less than 10000) making it harder to track, lol.

So far I have seen it happens with any of the other 2 heroes, but the Executor is just so noticeable because of the amount drop.

One workaround for now is to disable autocast in the command center and manually go to recruit the hero if it dies in combat.


Hope this at least help other people, since is hard to track late game and solution is simple.

 

Those working on this mod do so in their own free time and for no pay.
Show your support for them by enabling ads on this site!