Those working on this mod do so in their own free time and for no pay.
Show your support for them by enabling ads on this site!

- Chatbox: For random chatting, mod questions/suggestions go in the actual forums.

Author Topic: Imperial Civil War 2.0 Startup Troubleshooting  (Read 28123 times)

0 Members and 1 Guest are viewing this topic.

January 17, 2017, 01:55:18 PMReply #100

Offline Aeradom

  • Brevet Admiral
  • ****
  • Posts: 29
  • Approval: +0/-0
    • View Profile
Re: Imperial Civil War 2.0 Startup Troubleshooting
« Reply #100 on: January 17, 2017, 01:55:18 PM »
Settings shouldn't matter for that. When it crashes, do you get an exception error or does it just drop, and does it happen in the base game?

Actually, I'm getting two crashes. The exception error I've since resolved by just not alt+tabbing. Slightly inconvenient but I can live with that. The other one is far more frustrating for two reasons. First and foremost is it just crashes. This will occur just as a battle (land or space). Whenever I hit the start battle button, game just drops. The second issue though and probably more odd, is that it deletes the last save. Generally speaking this is an autosave as it's right before a battle. But I have seen on a rare occassion when just saving the game it will delete that after crash.

And no problems running the vanilla game.

January 17, 2017, 02:11:50 PMReply #101

Offline Corey

  • Mod Leader
  • Administrator
  • Emperor
  • *****
  • Posts: 7,164
  • Approval: +349/-79
  • Dream Crusher
    • View Profile
Re: Imperial Civil War 2.0 Startup Troubleshooting
« Reply #101 on: January 17, 2017, 02:11:50 PM »
Try using Large Address Aware on the exe:
http://www.moddb.com/downloads/large-address-aware1

It's typically used for Sins, but it can help with a lot of older games.
I also have a YouTube channel where I talk about mod development and gaming, do tutorials, and Let's Plays. If you like the content, consider supporting it on Patreon


January 17, 2017, 11:02:09 PMReply #102

Offline Aeradom

  • Brevet Admiral
  • ****
  • Posts: 29
  • Approval: +0/-0
    • View Profile
Re: Imperial Civil War 2.0 Startup Troubleshooting
« Reply #102 on: January 17, 2017, 11:02:09 PM »
Try using Large Address Aware on the exe:
http://www.moddb.com/downloads/large-address-aware1

It's typically used for Sins, but it can help with a lot of older games.

Yeah, I tried that, but got an error 51 code which I'm not quite sure why that would be as my understanding is that error code occurs because it CANT use more than 2GB or RAM which that's what LAA is supposed to fix. Regardless, turns out it was an exception error that I was getting (I got it confused with a Direct 3D one that I managed to solve on my own).But is there something else I should be doing to stomp out that exception error? I forgot to mention that along with crashing upon trying to load the battle map, the other time is during an orbital strike. After reading the error report, I made sure the game was to be run as administrator.

Edit: Thought I'd let you know that after a little research, that doesn't work on steam versions of the game. Ultimately, I'll just have to buy the game on GOG whenever it goes on sale as it seems to of been tweaked to work with modern systems. But in the meantime any help is certainly appreciated. I looked at the other mods but none do what this one does and satisfies that itch just better.

Update: Steam doesn't like me messing with those executables. It would just crash the moment I tried opening it with administrator mode active. Ended up taking it off there to prevent it from occurring again. Still stuck with those pesky crashes though that at this point, not sure how to deal with it. I can provide the report if it would help you guys bug squash. But for now, I can be diligent with my saves and just play the game. The one thing I am puzzled and would like to hear your input on because I've never seen it before, is why does the game delete my last save when it crashes?
« Last Edit: January 17, 2017, 11:30:56 PM by Aeradom »

January 17, 2017, 11:37:24 PMReply #103

Offline Corey

  • Mod Leader
  • Administrator
  • Emperor
  • *****
  • Posts: 7,164
  • Approval: +349/-79
  • Dream Crusher
    • View Profile
Re: Imperial Civil War 2.0 Startup Troubleshooting
« Reply #103 on: January 17, 2017, 11:37:24 PM »
Does it happen every single time, or are there some battles or OBs where it doesn't? You said every other battle at first, but this is weird, so the more specific information you can give, the better.
« Last Edit: January 17, 2017, 11:49:49 PM by Corey »
I also have a YouTube channel where I talk about mod development and gaming, do tutorials, and Let's Plays. If you like the content, consider supporting it on Patreon


January 18, 2017, 07:03:53 PMReply #104

Offline Aeradom

  • Brevet Admiral
  • ****
  • Posts: 29
  • Approval: +0/-0
    • View Profile
Re: Imperial Civil War 2.0 Startup Troubleshooting
« Reply #104 on: January 18, 2017, 07:03:53 PM »
Does it happen every single time, or are there some battles or OBs where it doesn't? You said every other battle at first, but this is weird, so the more specific information you can give, the better.

Well, I can tell you one spot I can get it crash every time. If I'm in the middle of a game and I tried to load a separate save, the game will crash and delete said save. And it'll also crash if I try to save over an existing save. However, were I to exit out to the main menu and load the game, then everything's fine and it doesn't crash. Same is true by just creating a new save. I did go and make the folder that holds the save not "read-only" and that seems to of resolved the crashes when loading into a random space/land battle map. Unfortunately, I couldn't give you a pattern on that one because if there was one, I didn't see it.

Edit: If I had to guess, it's probably something to do with the Auto-Save mechanic. Wouldn't be the first game Auto-Save messes with the game after all.
« Last Edit: January 18, 2017, 08:13:50 PM by Aeradom »

September 09, 2017, 02:29:08 PMReply #105

Allanon

  • Guest
Re: Imperial Civil War 2.0 Startup Troubleshooting
« Reply #105 on: September 09, 2017, 02:29:08 PM »
My game crashes on startup, Stormtrooper picture comes up then crashes to desktop. Regular Empire at War runs fine, I also am able to run the ACM2.4 mod without any problems. I have installed the ram update, I just did a fresh install of the retail gold pack, I looked in the mod directory as well as the FOC main directory for logfiles, but I didn't find any. One other thing: does this mod work on 32 bit machines? because my computer is a 32bit... or maybe the graphics aren't powerful enough, after all it's really not a great computer. And are there specific operating systems this has to be run on? Because I have a dual xp/win 7 installation, and I'm trying this in the xp environment. I'll be grateful for any help with this.

September 19, 2017, 02:01:36 PMReply #106

Omni

  • Guest
Re: Imperial Civil War 2.0 Startup Troubleshooting
« Reply #106 on: September 19, 2017, 02:01:36 PM »
I have a trouble. Game breaks after stormtrooper screen, almost instantly. I  use Gold edition of game from GOG. RAM fix applied.

 

Those working on this mod do so in their own free time and for no pay.
Show your support for them by enabling ads on this site!